Secure-Boot Problem mit Mint-Cinnamon

  • Linux Mint 21.3 Cinnamon


    Hallo

    Habe ich nicht vor einiger Zeit im Netz aufgeschnappt,
    das Linux-Mint Cinnamon nun auch mit aktivierten Secure-Boot funktioniert soll?
    Jedenfalls habe ich nun ein Problem mit Secure-Boot und Mint.

    Wird wohl an meine Unwissenheit liegen!

    Vorab erklärt:
    Bis Dato hatte ich eine Paralellinstallation mit "Windows Pro 10" und "Linux Mint Cinnamon".
    Beides lief soweit tadellos.

    Nun habe ich mich - mehr oder weniger notgedrungen dazu entschlossen,
    mein Windows Pro 10 auf Pro 11 zu upgraden.
    Dazu musste ich als WinPro11-Vorbedingung jedoch "Secure Boot" und "TPM" im UEFI aktivieren.
    Dies war dann auch schnell erledigt und WinPro11 liess sich ohne Probleme installieren.

    Auch Linux funktionierte ebenfalls normal - bis auf die nun sehr niedrige Graka-Auflösung,
    welche sich auch nicht mehr ändern liess. Also installierte ich den aktuellen NVIDIA-Grakatreiber,
    welcher mir über die Treiberverwaltung angeboten wurde.
    Die Auflösung war nun wieder wie gewohnt und beide Systeme laufen ohne Probleme.

    Heute allerdings erschien ein Kernel-Update

    (Linux-Kernel Update 5.15.0-106.116)
    in der Aktualisierungsverwaltung.
    Diesen wollte ich installieren, jedoch erscheint dabei eine Fehlermeldung.
    Ich vermute stark, dass diese Fehlermeldung mit dem nun aktivierten Secure-Boot zu tun hat.


    Ich weiss nun nicht, wie ich diesen Fehler beheben soll
    und befürchte auch, das zukünftige Updates unter Linux Mint ebenfallls Probleme machen könnten.


    Hier die Fehlermeldung:

    Quote

    EIN FEHLER IST AUFGETRETEN. Folgende Detailinformation werden angeboten:
    E: Der dpkg-Prozess wurde unterbrochen; Sie müssen manuell »dpkg --configure -a« ausführen, um das Problem zu beheben.
    E: _cache->open() failed, please report.

    Code
    Daraufhin habe ich über das Terminal
    SUDO dpkg --configure -a
    ausgeführt.

    Dort wurde dann irgendetwas durchgeführt und anschliessend
    etwas auf englisch von mehrfacher Passworteingabe während des Neustarts bei "MOK" oder so usw., erwähnt,
    was ich nicht kapiert habe. Als Überschrift wurde dabei Secure-Boot aufgeführt.

    Momentan stehe ich auf dem Schlauch und bin ratlos was ich tun muss,
    damit ich das Kernel-Update und auch künftige andere Updates wieder über die Aktualisierungsverwaltung installieren kann.

    Ich vermute und hoffe aber mal, dass es bei ganzen Problematik nur um Passworteingaben geht (Secure-Passwort?),
    wenn man weiss wo. Ich erhalte diesbezüglich allerdings keine automatisch erscheinenden Passwortabfragen seitens Linux.

    Kann mir da bitte jemand weiterhelfen?

  • In der MOK Verwaltung mit den blauen Screen musst du den Secure Boot Key ausrollen.


    Hier gibt es dazu eine deutschsprachige Step-for-Step Anleitung: https://www.dell.com/support/kbdoc/…re-boot-enabled

    --
    Ciao!

    Linux Nutzer seit über 20 Jahren. I ❤️ Freedom!

    Offizieller Proton-Botschafter aus der Schweiz 🇨🇭 😅

    Meine Haupt-Distribution ist Ubuntu.

    Mein Blog: https://rueegger.me

    Wer meinen sinnlosen Gedanken folgen möchte, kann dies gerne auf Mastodon tun: https://swiss.social/@srueegger

  • Hallo Kim

    Danke für den Link.
    Diese Seite hatte ich allerdings bei meinen gestrigen Recherchen zum Thema bereits entdekt.
    Nun ist es bei mir aber so, dass beim starten von Linux dieser MOK-Screen gar nicht mehr erscheint.

    Habe mal Testweise versucht den MOK-Screen mittels

    Code
    sudo update-secureboot-policy --enroll-key

    beim nächsten Neustart zu erzwingen. Allerdings tauchte dieser auch damit nicht auf.

    Dennoch bin ich dem MOK-Scren bereits einmal unerwartet begegnet
    und zwar nach der Aktivierung von Secure-Boot und TPM.

    Als ich nach dieser UEFI-Änderung Linux startete war ja - wie bereits
    kurz erwähnt, meine Bildschirmauflösung plötzlich im Keller
    und die Einstelloptionen bzgl. der Auflösung waren alle ausgegraut,
    so dass ich sie nicht ändern konnte.
    Desshalb habe ich dann über Treiberverwaltung den aktuellsten
    Graka-Treiber installiert.
    Nach Abschluss dieser Installation (oder beim nachfolgenden Neustart, das weiss ich jetzt nicht mehr),
    erschien dann überraschend dieser MOK-Screen, womit ich überhaupt nichts anfangen konnte!
    Irgendie habe ich dass Teil dann wegbekommen und seit dem nicht mehr wiedergesehen *fg

    Linux Mint läuft soweit aber ganz normal, nur lässt sich halt das aktuelle Kernel-Update nicht installieren,
    und es erscheint die besagte Fehlermeldung die auf Zusammenhänge mit Secure-Boot deutet.
    Ob es ähnliche Probleme auch bei noch kommenden Updates geben wird, steht noch offen.

    Habe gelesen, das man "Secure-Boot" nach erfolgreich durchgeführter Windows 11 -Installation
    auch wieder deaktivieren kann. Windows 11 würde dann auch weiterhin funktionieren.
    Es käme dann nur zu einigen wenigen Einschränkungen unter Windows, welche für mich jdeoch
    in der Praxis irrelevant wären.

    Bange habe ich jedoch zunächst, dass durch eine Deaktivierung von Secure-Boot
    unvorhersehbare schwerwiegende Probleme irgend einer Art auftreten könnten!

    Für absolute Notfälle habe ich aber ein Full-Image im Ärmel,
    welches ich vor Beginn all meiner Aktionen erstellt habe.

    Mein Plan ist nun zunächst abzuwarten, bis irgendwelche weiteren Linux-Updates auftauchen.
    Dann wird sich zeigen, ob es generelle Probleme beim Updaten gibt,
    oder ob es nur das aktuelle Kernel-Update betrifft.
    Könnte aber auch sein, dass das Problem nun alle zukünftigen Kernel-Updates betreffen wird.
    Das wäre allerdings Fatal auf langer Sicht.

    Nachtrag:
    Kann mir vielleicht jemand aus der Praxis sagen,
    ob es zu Bootproblemen bei Linux Mint (und/oder bei Windows Pro 11) kommen könnte,
    wenn ich nun Secure-Boot einfach wieder deaktivieren würde?

    Edited once, last by doppelstern (May 8, 2024 at 2:16 PM).

  • Ich bin kein grosser Windows Experte, aber ich glaube Windows 11 verlangt den Secure Boot zwingend.

    Wo genau ist das Problem nun? Also was funktioniert nun nicht?

    --
    Ciao!

    Linux Nutzer seit über 20 Jahren. I ❤️ Freedom!

    Offizieller Proton-Botschafter aus der Schweiz 🇨🇭 😅

    Meine Haupt-Distribution ist Ubuntu.

    Mein Blog: https://rueegger.me

    Wer meinen sinnlosen Gedanken folgen möchte, kann dies gerne auf Mastodon tun: https://swiss.social/@srueegger

  • Das einzigste was seit der Aktivierung von Secure-Boot und TPM
    nicht mehr funktioniert ist, das updaten des Linux-Kernels.
    Ansonsten gibt es in beiden Systemen derzeit keinerlei Probleme.

    Wenige Tage vor dem aktivieren von Secure-Boot und TPM
    hatte ich noch ein Kernel-Update durchgeführt.
    Mein derzeit installierter Kernel hat somit die Versionsnummer: 5.15.0-105-generic.

    Meine Befürchtung ist halt, das ich zukünftig keine Kernel-Updates
    mehr durchführen kann und zwar vielleicht desshalb, weil Secure-Boot aktiviert ist.

    In meinem Eingangspost hatte ich ja bereits die Fehlermeldung zitiert welche nun erscheint, wenn ich versuche das aktuelle Kernel-Update zu installieren. Und der in dieser Fehlermeldung enthaltene Vorschlag zur Behebung des Fehlers funktioniert nicht.

    Edited once, last by doppelstern (May 9, 2024 at 8:46 AM).

  • Nur wenige Minuten später:
    Erstmalig passierte bei mir soeben folgendes unter Linux-Mint.
    Während meiner Arbeit hier im Forum wurde der Bildschirm plötzlich schwarz
    und es erschien eine Passwortabfrage (mit Linux-Logo in der Mitte). Sieht nach dem Benutzeranmeldungsfenster aus.
    Ist bisher noch nie vorgekommen und mein System ist zudem auf automatische Benutzeranmeldung eingestellt.
    Musste meinen PC manuell ausschalten.
    Seltsam!

    Edited once, last by doppelstern (May 9, 2024 at 10:23 AM).

  • Ich verstehe immer noch das Problem nicht ganz. Daher kannst du möglichst konkret und in wenigen Worten beschrieben wo du gerade anstehst.

    --
    Ciao!

    Linux Nutzer seit über 20 Jahren. I ❤️ Freedom!

    Offizieller Proton-Botschafter aus der Schweiz 🇨🇭 😅

    Meine Haupt-Distribution ist Ubuntu.

    Mein Blog: https://rueegger.me

    Wer meinen sinnlosen Gedanken folgen möchte, kann dies gerne auf Mastodon tun: https://swiss.social/@srueegger

  • Ich verstehe was du alles getan hast aber nicht wo dein Problem konkret liegt. Was genau für eine Aktion (z.b. Kernel Update über Aktualisierungsverwaltung oder sowas) machst du und welche Fehlermeldung kommt.

    Helfen können wir nur mit konkreten Fehlermeldungen und dem wissen welche Aktions die verursacht hat.

    --
    Ciao!

    Linux Nutzer seit über 20 Jahren. I ❤️ Freedom!

    Offizieller Proton-Botschafter aus der Schweiz 🇨🇭 😅

    Meine Haupt-Distribution ist Ubuntu.

    Mein Blog: https://rueegger.me

    Wer meinen sinnlosen Gedanken folgen möchte, kann dies gerne auf Mastodon tun: https://swiss.social/@srueegger

  • Also aktuell taucht nun (neben den bereits Eingangs erwähnten Problem) zusätzlich folgendes Problem auf:

    Der Bildschirm wird unter Linux Mint plötzlich mitten in der Arbeit (also NICHT während einer Inaktivitäts-Pause) schwarz und am linken Rand erscheint ein Eingabefeld zur Passworteingabe. Dies ist jetzt bereits zwei mal binnen 60 Minuten aufgetreten. Da ich mein Adminpassswort nicht im Kopf habe, musste ich meinen Rechner manuell neu starten.

    Warum erscheint nun plötzlich automatisch und grundlos eine Passwortabfrage (mit Linux-Logo) ?

    Linux ist so eingestellt, das beim Rechnerstart ein automatisches Login ohne Passwortabfrage erfolgt.

    Auch habe ich nichts unternommen, damit sich Linux Mint zeitgesteuert abmelden soll.

    Ich hoffe, das ich mich diesesmal verständlich ausgedrückt habe :D

    Edited once, last by doppelstern (May 9, 2024 at 11:53 AM).

  • Habe nich entschieden, über Timeshift mein vor 17 Tagen erstelltes Image wieder zurückzuspielen.
    Habe zuvor Secure-Boot und TPM im UEFI wieder deaktiviert.
    Beide Systeme liessen sich danach problemlos starten und zeigen keine unauffälligkeiten. Das ist schon mal die halbe Miete :)
    Ich gehe davon aus, dass meine Probleme damit behoben sind.

    Die genauen Ursachen für meine letzten Probleme unter Linux Mint konnte ich nicht ausmachen.
    Kann sein, dass es an dem letzten Kernel-Update lag oder / und im Zusammenhang mit der Aktivierung von Secure-Boot.
    Wie dem auch sei, zukünftig werde ich mit dem updaten von Linux-Kernel's vorsichtiger sein
    und solange das System Problemlos läuft, wohl keine Kernel-Updates mehr durchführen, wenn dies nicht aus besonderen Gründen erforderlich ist.

  • Linux ist so eingestellt, das beim Rechnerstart ein automatisches Login ohne Passwortabfrage erfolgt.

    Das passiert in der Regel immer bei Autologin, wenn du danach ein Programm öffnest das auf den Schlüsselbund zugreifen will. Der Schlüsselbund ist mit deinem (wahrscheinlich ursprünglich) eingerichtetem Passwort gesichert. Bei Desktop Anmeldung mit Passwort wird der direkt entsperrt - bei Auto-Login entfällt das und sobald ein Programm auf Inhalte im Schlüsselbund zugreifen will - kommt die entsprechende Passwortabfrage.


    Lösen kannst du das indem du den Schlüsselbund öffnest und ein neues Passwort für den "Anmelden" Schlüsselbund eingibst und das neue Passwort dann einfach "leer" bleibt.

    --
    Ciao!

    Linux Nutzer seit über 20 Jahren. I ❤️ Freedom!

    Offizieller Proton-Botschafter aus der Schweiz 🇨🇭 😅

    Meine Haupt-Distribution ist Ubuntu.

    Mein Blog: https://rueegger.me

    Wer meinen sinnlosen Gedanken folgen möchte, kann dies gerne auf Mastodon tun: https://swiss.social/@srueegger

  • Nachdem ich viele Stunden vergebens damit verbracht habe eine Lösung für die geschilderten Probleme zu finden und weitere Versuche nur ein herumstochern im Dunkeln gleich gekommen wären, hielt ich meine Vorgehensweise für die beste Methode. Dies bestätigt auch das Resultat meiner Aktion in der Praxis, denn Windows Pro 11 als auch Linux Mint Cinnamon laufen nun wieder rund und ohne jegliche Probleme.

    Edited 2 times, last by doppelstern (May 10, 2024 at 11:12 AM).

  • aber ich glaube Windows 11 verlangt den Secure Boot zwingend

    Für die Installation von Windows 11 mag das zutreffen. Aber im laufenden Betrieb wird Secure Boot scheinbar nicht permanent abgefragt. Ich arbeite im Dualboot und immer mal wieder mit unterschiedlichen Linux-Distributionen. Für Arch Linux musste ich Secure Boot deaktivieren und konnte so trotzdem Windows 11 nutzen. Es gab Updates und alles war fein. So lief Windows 11 ohne Secure Boot ein paar Wochen lang. Gestern habe ich Secure Boot nun wieder aktiviert, da ich jetzt mit Fedora Linux unterwegs bin und Fedora von Hause aus Secure Boot unterstützt. ;)

    Arch Linux | Gnome 46.2 | Kernel 6.9.2-arch1-1

    MSI MAG X570 Tomahawk WIFI | AMD Ryzen 9 3900X | 2x 16 GB G.Skill RipJaws V DDR4-3200 | Sapphire NITRO+ AMD Radeon RX 7800 XT | Seasonic Prime PX-750 80+ Platinum

  • Soweit ich informiert bin, muss Secure-Boot nicht einmal aktiviert sein bei einer Win11 installation. Lediglich die Option Secure-Boot muss vorhanden sein.

    Mich beschleicht übrigens der Verdacht, dass ich bei der Eingangs beschriebenen Problematik ( defekter dpkg-Prozess und daraufhin plötzliche und grundlos erscheinenende Passwortabfragen), Opfer der jüngsten Linux-Attacke geworden war. Das zurückspielen meines Linux-Backups war auf jedem Fall richtig gewesen. Die Manipulation soll bereits gefixt sein.

    Falls ihr von dieser Linux-Attacke noch nichts mitbekommen habt, solltet ihr euch diese Folge des Computerclubs ansehen:

    Der Osterkrimi: Hintertür per Update? (CC2tv Folge 373)
    Website: https://www.cc2.tvSpenden: https://paypal.me/cc2tvEs ist üblich, dass freie Software nicht nur offen zur Verfügung gestellt wird, sondern dass Enthu...
    www.youtube.com

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!