Manjaro - Failed to open key file

  • Hallo,


    wie ich in einem anderen Beitrag schon mal geschrieben habe, bekomme ich eine Fehlermeldung beim starten und nachdem ich das Kennwort für die Verschlüsselung eingegeben habe:


    Bisher habe ich nur einen Reddit Beitrag gefunden der aber nicht wirklich viel aussagt.

    Folgendes steht jedenfalls in der crypttab

    Code
    # <name>               <device>                         <password> <options>
    luks-2d8804e8-50e9-4168-a275-96a714ea0ad0 UUID=2d8804e8-50e9-4168-a275-96a714ea0ad0     /crypto_keyfile.bin luks
    luks-b860186b-b112-4db9-9921-b4f4b62cfcef UUID=b860186b-b112-4db9-9921-b4f4b62cfcef     /crypto_keyfile.bin luks

    1) ist die Hauptpartition

    2) ist der SWAP


    beides wurde aber entschlüsselt.

  • Hi


    Ja da fehlt was ich möchte erst mal probieren inwieweit das mit der zweiten Fehlermeldung zusammen hängt.

    Ob die zweite Fehlermeldung nur durch die erste produziert wird oder nicht.


    -->failed to start backlight <--


    und danach wenn der Fehler eliminiert ist was danach gemeldet wird.

    -->error resume:hibernation device


    Hibernation not working, need help
    I want to use hibernation with a LUKS encrypted main partition. Problem is, the machine state is not saved. After selecting “Hibernation” in the logout screen,…
    forum.manjaro.org

    How do I fix Manjaro error hibernation device not found on boot?
    After installing updates and restarting I got these errors. ERROR: resume: hibernation device 'UUID=long number here' not found ERROR: device…
    superuser.com

    Linux – How to fix Manjaro error hibernation device not found on boot – iTecTec

    Error: Manjaro error hibernation device not found on boot
    ERROR: resume: hibernation device 'UUID=long number here' not found ERROR: device 'UUID=long number here' Skipping fsck. mount: /new_root: can't find…
    archived.forum.manjaro.org


    Weil diese Meldung kann wenn ich das richtig sehe vielfach interpretiert werfen.

    Ich weiß noch nicht wo ich da ansetzen soll.

    Die Fehlermeldung ist zwar andererseits eindeutig aber...

    Vielleicht habe ich aber auch im Moment einen logischen Aussetzer. ;)


    Nur wenn wir den einen Error weg haben (oder eben auch nicht) können wir vielleicht uns mehr auf den anderen konzentrieren.

  • Ich versteh halt nicht warum dann alles läuft, weil wenn ich das richtig verstehe mit der aller ersten Meldung sollte der doch die Platte nicht entschlüsseln können? Oder ist der Key nicht als Schlüssel gemeint sondern eher als Schlüsselelement?


    Und ja das könnte dann natürlich das auslesen vom backlight verhindern

  • Ich versteh halt nicht warum dann alles läuft, weil wenn ich das richtig verstehe mit der Meldung sollte der doch die Platte nicht entschlüsseln können?

    Ja das sagt das zumindest aus.


    Nur der Fehler stellt sich wenn ich das richtig verstehe in der Regel nur nach updates ein und du hast doch keine gefahren oder ?


    Sonst Probier das doch mal direkt aus.


    Code
    In etc/default/grub the line GRUB_CMDLINE_LINUX_DEFAULT=… must contain the identifier as a device, not as a UUID. Even if that device has that UUID. With the data from my OP: I replaced resume=/dev/disk/by-uuid/33333333-3333-3333-3333-333333333333 with resume=/dev/mapper/crypt_sda2 a… 

    Sieh dir doch bitte mal den ersten Link im # 4 an.

  • Nur der Fehler stellt sich wenn ich das richtig verstehe in der Regel nur nach updates ein und du hast doch keine gefahren oder ?

    Gestern gab es einige Updates aber der Fehler kam schon davor quasi seit der Installation und dem ersten neustart bzw start.


    Komm aber erst nach der Arbeit an das Notebook.

  • Gestern gab es einige Updates aber der Fehler kam schon davor quasi seit der Installation und dem ersten neustart bzw start.

    Puh das bedeutet du hast noch gar nichts Elementares installiert.

    Wäre es da nicht eventuell besser das System neu auf zu setzen.

    Bevor du in der grub Änderungen machst.

  • Mittlerweile ist es schon fertig eingerichtet und ich arbeite damit :whistling:

    Nee dann Probier das mal bitte aus.


    Code
    In etc/default/grub the line GRUB_CMDLINE_LINUX_DEFAULT=… must contain the identifier as a device, not as a UUID. Even if that device has that UUID. With the data from my OP: I replaced resume=/dev/disk/by-uuid/33333333-3333-3333-3333-333333333333 with resume=/dev/mapper/crypt_sda2 a… 

    Dann bitte erst mal testen.

  • Das Kennwort hast du ja mit Sicherheit richtig eingegeben auch mit Gross/Kleinschreibung.

    Sorry ich will dich nicht nerven aber mir passiert das auch öfters.

    Ja sonst würd ich ja nicht ins System kommen, aber kann die Frage verstehen^^

    Und wenn ich im System bin komm ich auch auf alle Partitionen bzw sumvolumes

  • Ja sonst würd ich ja nicht ins System kommen, aber kann die Frage verstehen^^

    Und wenn ich im System bin komm ich auch auf alle Partitionen bzw sumvolumes

    Deshalb habe ich den Teil auch schon vorher gelöscht. ;)

    Nur ich weiss nicht wenn du kein update gemacht hast wo ich sonst ansetzen soll.

    Ein relativ frisch installiertes System produziert imho solche Fehler nicht. :huh:

    Deshalb suche ich den Weg der uns zum Ziel führt...

  • Aber wenn ich die etc/default/grub verändere, kann und der erkennt dann das nicht, kann ich nicht mehr ins System oder? Wobei es sich ja nur ums SWAP handelt, da weiß ich gar nicht wie Linux dann reagiert wenn das nicht erreichbar ist.

  • Aber wenn ich die etc/default/grub verändere, kann und der erkennt dann das nicht, kann ich nicht mehr ins System oder?

    Auszuschließen ist das nicht !

    Ist zwar in diesem Fall selten, nur möglich ist das.

    Obwohl der Rest nicht berührt wird.

    Nur ich weiß nicht wo ich sonst ansetzen soll ?


    Vielleicht finde ich noch einen anderen Weg.

    Da muss ich mich heute Abend mal mit beschäftigen.

  • Dann mach ich mal noch ein TImeshift Snap auf ne Externe platte^^

    Ist wohl besser.

    Ich habe jetzt nochmals ziemlich intensiv gesucht, finde aber leider nirgends Hinweise wie das anders zu handhaben ist.

    Alles was ich finde deutet nur auf update Error hin und steht in keinem Zusammenhang mit einer Installation.

    Ich weiß ehrlich gesagt so langsam nicht mehr weiter.

    Vielleicht fällt einem anderen Forums Member noch was dazu ein mir fällt auch aus meiner Sicht nichts mehr ein um ehrlich zu sein.

    Vielleicht ist da jemand der sich mit Manjaro gut auskennt und was dazu weiß ??

    Ich weiß auch nicht ob das Problem damit behoben wird, ich kann nur hoffen aber sonst....


    Vielleicht findest du aber auch hier was.


    Manjaro-Linux-Forum - Manjaro Linux Forum

  • Alles was ich finde deutet nur auf update Error hin und steht in keinem Zusammenhang mit einer Installation.

    Ich weiß ehrlich gesagt so langsam nicht mehr weiter.

    Ja, habe ich auch schon öfters gelesen; vor allem schwierig weil außer der Meldung das ganze gar keine Auswirkungen zu haben scheint.


    Hab schon mal überlegt neu zu installieren vielleicht mal nicht mit der minimalversion. Wobei dann muss man so viel Pakete entfernen die ich gar nicht brauche/will.

    Aber eig. sollte das ja kein Problem der minimalversion sein.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!