SSH einrichten - Ich bin wohl zu blöd

  • Hallo Gemeinde,


    ich möchte meine 3 Linux-Rechner im Heimnetz gerne per SSH verbinden (1x mein PC, 1x mein Lappi und 1x mein HTPC), aber irgendwie bekomme ich das nicht hin. Alle Rechner hängen per LAN oder WLAN an einer Fritte 6591 im selben Netzwerk (SSID), alle habe eine feste IP, auf allen läuft LM 21.1. Auf allen Geräten habe ich auch via


    sudo apt update

    sudo apt-get install openssh-server


    die nötige SW installiert, die angeblich auch direkt nach der Installation lauffähig sein soll, aber es klappt auch nach einem Neustart nicht. Will ich z. B. via Terminal von meinem PC auf den HTPC zugreifen (feste IP 192.168.178.24) zugreifen, dann erhalte ich nach einiger Zeit folgende Meldung(en):


    juergen@KPC:~$ ssh 192.168.178.24

    ssh: connect to host 192.168.178.24 port 22: Connection timed out

    juergen@KPC:~$ ssh HTPC@192.168.178.24

    ssh: connect to host 192.168.178.24 port 22: Connection timed out

    juergen@KPC:~$

    sudo service ssh status

    [sudo] Passwort für juergen:

    ● ssh.service - OpenBSD Secure Shell server

    Loaded: loaded (/lib/systemd/system/ssh.service; enabled; vendor preset: e>

    Active: active (running) since Sat 2023-01-21 21:05:07 CET; 1h 1min ago

    Docs: man:sshd(8)

    man:sshd_config(5)

    Process: 1234 ExecStartPre=/usr/sbin/sshd -t (code=exited, status=0/SUCCESS)

    Main PID: 1264 (sshd)

    Tasks: 1 (limit: 18788)

    Memory: 2.9M

    CPU: 54ms

    CGroup: /system.slice/ssh.service

    └─1264 "sshd: /usr/sbin/sshd -D [listener] 0 of 10-100 startups"

    Jan 21 21:05:07 KPC systemd[1]: Starting OpenBSD Secure Shell server...

    Jan 21 21:05:07 KPC sshd[1264]: Server listening on 0.0.0.0 port 22.

    Jan 21 21:05:07 KPC sshd[1264]: Server listening on :: port 22.

    Jan 21 21:05:07 KPC systemd[1]: Started OpenBSD Secure Shell server.

    lines 1-17/17 (END)


    Da ich weiß, dass 99% aller Fehler vor der Tastatur sitzen, jetzt meine Frage in die Runde: Was mache ich falsch, was habe ich vergessen oder was auch immer? Auch im Nemo-Explorer -> Netzwerk wird mir der HTPC nicht angezeigt.


    Grüßle, Jürgen

    Asus Z170PG | i7 6700K @4600 MHz | RTX 3060 | 32 GB RAM @4000 MHz | 1x 1 TB SSD | 1x 1 TB HDD | 1x 29" UWFHD | 2x 22" FHD und diverse Audio-HW

  • Was passiert denn bei

    Code
    sudo systemctl start ssh.service

    Daily Driver PC: Pop!_OS 22.04 + Win 10 Dual Boot/ Intel i7-7700K / NVIDIA GeForce GTX 1070 / 32 GB RAM / 3x 1TB Samsung SSD

    Daily Driver Laptop: HP Elitebook x360 1030 G2 / Pop!_OS 22.04 + Win 11 Dual Boot / Intel i5-7200U / Intel HD 620 / 8 GB RAM / 500 GB Samsung NVMe

    Retro-Spiele PC: Manjaro XFCE / Intel i5-4670K / NVIDIA GeForce GTX 760 / 16 GB RAM / 250 GB Samsung SSD

    Couch Laptop: Dell Latitude E6220 / Linux Mint 21 Cinnamon / 8 GB RAM / 250 GB Samsung SSD

  • Ah, die Sonne geht (ein wenig) auf. Mit Deinem Tipp

    Code
    sudo ufw allow ssh

    Habe jetzt zumindest via Terminal Zugriff auf den HTPC:

    Leider wird mir der HTPC noch nicht in Nemo angezeigt, aber herrje... Führe gleich mal einen Neustart durch um zu sehen, ob es dann immer noch funktioniert.

    Asus Z170PG | i7 6700K @4600 MHz | RTX 3060 | 32 GB RAM @4000 MHz | 1x 1 TB SSD | 1x 1 TB HDD | 1x 29" UWFHD | 2x 22" FHD und diverse Audio-HW

  • Jawoll, auch nach einem Neustart habe ich jetzt via Konsole Zugriff auf den HTPC:


    Code
    juergen@KPC:~$ ssh 192.168.178.24
    juergen@192.168.178.24's password: 
    Last login: Sat Jan 21 23:05:51 2023 from 192.168.178.20
    juergen@HTPC:~$

    Jetzt nur noch die Frage: Wie bekomme ich den Zugriff in Nemo hin?

    Asus Z170PG | i7 6700K @4600 MHz | RTX 3060 | 32 GB RAM @4000 MHz | 1x 1 TB SSD | 1x 1 TB HDD | 1x 29" UWFHD | 2x 22" FHD und diverse Audio-HW

  • Fairerweise war es ja ein Tipp von faxxy und El Pollo Diablo und nicht von mir.

    Ich bin kein grosser Nemo Experte aber unter Nautilus mache ich das folgendermassen:


    • Ich öffne Nautilus
    • Drücke dann die Tastenkombination "Strg + L"
    • Dann kann ich oben in der Pfadliste eine Adresse eingeben
    • dort gebe ich dann, ähnlich wie im Terminal folgendes ein: "ssh://nutzer@ip" dann Einagbetaste
    • Dann sollte ein Fenster aufgehen wo du das Passwort eingeben kannst, du kannst das Passwort auch im Schlüsselbund speichern (sollte eine Checkbox sein)
    • Und schon bist du verbunden.
    • Du kannst dann die einzelnen SSH-Ordner quasi links in Seitenleiste ziehen für zukünftigen Schnellzugriff
  • JAAA! Das hat funktioniert. Supi. Wenn Du eine Frau wärst, dann würde ich dich jetzt küssen - mit Zunge! ;););)


    Nein, ernsthaft: Vielen Dank für Deine Hilfe. War ja eigentlich auch nicht wirklich kompliziert, aber ich bin seit über 30 Jahren aus irgendwelchen "DOS"-Programmierungen und Konsorten raus... oh je - Und Linux nutze ich auch erst seit knapp einem Jahr. Da muss ich noch (wieder) viel lernen.


    Grüßle, Jürgen

    Asus Z170PG | i7 6700K @4600 MHz | RTX 3060 | 32 GB RAM @4000 MHz | 1x 1 TB SSD | 1x 1 TB HDD | 1x 29" UWFHD | 2x 22" FHD und diverse Audio-HW

  • Also ich habe jetzt keine weiteren Einstellungen und Änderungen vorgenommen, frei nach dem Motto: Never change a running system. Ich benötige SSH auch nur für den gelegentlichen Zugriff - und dafür reicht's und es klappt. Mein "richtiges" NAS hängt auch via LAN an der Fritte. Oder "notfalls" übertrage ich auch via Warpinator. SSH ist daher nur sowas wie eine weitere, zusätzliche Zugriffsmöglichkeit.


    Dennoch vielen Dank für die weiteren Tipps. Werde mich damit bei Gelegenheit mal näher befassen.

    Asus Z170PG | i7 6700K @4600 MHz | RTX 3060 | 32 GB RAM @4000 MHz | 1x 1 TB SSD | 1x 1 TB HDD | 1x 29" UWFHD | 2x 22" FHD und diverse Audio-HW

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!