[gelöst] Mehr als ein DVD Laufwerk geht nicht?

  • Hat jemand schon mal von irgendwelchen Problemen gehört wenn man mehr als 1 DVD Laufwerk am PC hat?

    Das Linux läuft völlig problemlos mit einem DVD-ROM. Sobald man ein zweites anschließt und dann mal die Schublade öffnet, per "Eject" Befehl, friert der Rechner ein. Das kann man reproduzieren an verschiedenen SATA Anschlüssen und mit verschiedenen Laufwerken. Ich habe mehrere Laufwerke (3-5 Stück) angeschlossen und alle werden auch inklusive eingelegter DVDs erkannt.

    Aber sobald man die Schubladen öffnet friert der PC anschließend ein.

    Ich frage mich nun wo ich suchen soll, ist das Linux schuld? Es zeigt /dev/sr0 bis /dev/sr5 ganz ordentlich an, alles da.
    Ist das Mainboard und oder die Controller schuld? Schon eher, oder?
    Es kann ja sein das es ein bekanntes Problem gibt von dem ich nichts weiß oder so. Ich werde morgen oder so ein anderes Linux probieren. Anderes Mainboard muss ich erstmal haben.

    Linux Debian 11

    Kernel 5.10

    Intel J1900 SoC CPU
    DVD-ROM per SATA angebunden, mehrere Varianten: per SoC, per Controller

    ----

    PC | AMD Ryzen 7 5700X | Radeon RX6600 | 32GB RAM | 1,5TB NVMe | Manjaro KDE Kernel 5.18 + Windows 11

    NB | AMD Ryzen 5 5300U | Radeon Vega 8 | 16GB RAM | 512GB NVMe | Debian 11 Kernel 5.18



  • Ist das erste Mal, dass ich so was höre. Ich habe mehrere PCs mit 2 optischen Laufwerken, ab und zu schließe ich zum testen noch ein drittes per USB an. Probleme gab es bisher keine.

    Ich benutze derzeit Debian 11, Manjaro und ArcoLinux. Aber auch mit älteren Debian-Versionen lief das alles.

    Schinder und Knarren, statt Kinder und Narren...

    Alles ist so unsagbar schnell geworden.
    (EROC, Let's Gläntz)


    Meine aktiven Maschinen:

    eeePCs, HP elitebooks, FSI Lifebooks

    Einige PCs, Hauptsächlich AMD

    Atari 800XL, Atari 130XE, Atari 1040STFM, Atari Falcon 030

    Sharp Zaurus SL 5500G, Palm PDAs m- und Tungsten Serie

    Casio SF- und PV- Serie.

  • Wie hast du denn den eject-Befehl eingegeben? Ohne Angabe des Gerätes oder in dieser Form? eject /dev/sr1


    Schau vielleicht in die Manpages, für eject gibt es einige Optionen.


    Auszug

  • Wie hast du denn den eject-Befehl eingegeben? Ohne Angabe des Gerätes oder in dieser Form? eject /dev/sr1


    Schau vielleicht in die Manpages, für eject gibt es einige Optionen.

    Das klingt interessant.

    Ja, ich verwende eject in der Form eject /dev/sr2 und zum Einziehen eject -t /dev/sr2


    Code
    eject --version
    eject from util-linux 2.36.1

    ----

    PC | AMD Ryzen 7 5700X | Radeon RX6600 | 32GB RAM | 1,5TB NVMe | Manjaro KDE Kernel 5.18 + Windows 11

    NB | AMD Ryzen 5 5300U | Radeon Vega 8 | 16GB RAM | 512GB NVMe | Debian 11 Kernel 5.18



  • ...und die Option -v (verbose) dazunehmen

    Code
    eject -v /dev/sr0
    
    eject: Gerätename ist »/dev/sr0«
    eject: /dev/sr0: nicht eingehängt
    eject: /dev/sr0: ist ein gesamtes Laufwerk
    eject: /dev/sr0: Auswerfen wird mittels Auswurfbefehl für CD-ROM versucht
    eject: CD-ROM-Auswurfbefehl erfolgreich
  • ...und die Option -v (verbose) dazunehmen

    Das erste hat geklappt, dann 10 Sekunden später gleich das zweite gemacht und zack Rechner eingefroren:



    Daher nur Screenshot als Bild möglich.

    ----

    PC | AMD Ryzen 7 5700X | Radeon RX6600 | 32GB RAM | 1,5TB NVMe | Manjaro KDE Kernel 5.18 + Windows 11

    NB | AMD Ryzen 5 5300U | Radeon Vega 8 | 16GB RAM | 512GB NVMe | Debian 11 Kernel 5.18



  • Das erste hat geklappt, dann 10 Sekunden später gleich das zweite gemacht und zack Rechner eingefroren:



    Daher nur Screenshot als Bild möglich.

    Schade, hatte gehofft, dass dort etwas mehr zu sehen ist. :(


    Anscheinend bekommt eject gar nicht mit, dass es hintenraus kracht, wenn es "succeeded" vermeldet.


    Vielleicht noch ein zweites Terminal parallel öffnen und mit journalctl -kf die Systeminformationen live anschauen.

  • Schade, hatte gehofft, dass dort etwas mehr zu sehen ist. :(


    Anscheinend bekommt eject gar nicht mit, dass es hintenraus kracht, wenn es "succeeded" vermeldet.

    Ja, das kommt mir auch so vor.
    Ich glaube das Beste wird sein wenn ich erst mal ein anderes Mainboard nehme. Am Ende hat das Board irgendwelche Beschränkungen aufgrund knapper PCIe Lanes und oder knapper Interrupts oder sowas und macht deswegen Probleme.
    Der J1900 ist ja ein toller stromsparender SoC und möglicherweise nicht für mein Szenario gedacht.

    ----

    PC | AMD Ryzen 7 5700X | Radeon RX6600 | 32GB RAM | 1,5TB NVMe | Manjaro KDE Kernel 5.18 + Windows 11

    NB | AMD Ryzen 5 5300U | Radeon Vega 8 | 16GB RAM | 512GB NVMe | Debian 11 Kernel 5.18



  • ...und die Option -v (verbose) dazunehmen

    Nachtrag und Ende:


    Es lag tatsächlich am Mainboard.

    Man merke sich: das Asrock Q1900-ITX mit dem SoC J1900 ist ein wunderbares stromsparendes Board mit einem tollen 4-Kern SoC, braucht nur 10 Watt und läuft super als MIni-NAS und kleiner Server etc. - aber niemals mehr als ein optisches Laufwerk anschließen!

    Ich habe in der Bastelkiste noch ein AMD Mainboard FM2A88M-HD+ mit schöner A8 APU gefunden, das hat sogar 8 SATA6 Anschlüsse und funktioniert mit mehreren DVD ROM Laufwerken problemlos in Debian 11.

    ----

    PC | AMD Ryzen 7 5700X | Radeon RX6600 | 32GB RAM | 1,5TB NVMe | Manjaro KDE Kernel 5.18 + Windows 11

    NB | AMD Ryzen 5 5300U | Radeon Vega 8 | 16GB RAM | 512GB NVMe | Debian 11 Kernel 5.18



  • harihegen

    Changed the title of the thread from “Mehr als ein DVD Laufwerk geht nicht?” to “[gelöst] Mehr als ein DVD Laufwerk geht nicht?”.
  • Hallo ,

    wenn es dir hilft, versuche ich es gleich mit dem 2. cdlaufwerk. ich habe ein intern und eins extern welches ich zusätzlich anklemmen kann

    Das musst du nicht für mich machen.

    Ich habe mittlerweile ein System welches mehr als 5 DVD-ROM Laufwerke problemlos ansteuert.
    Vermutlich war der SoC Intel J1900, den ich ursprünglich verwendet hatte, einfach nicht dafür ausgelegt.


    Jetzt arbeitet ein AMD A88X FCH genau für diese Aufgabe, wobei auch hier eine Mischbestückung mit Brennern keine gute Idee zu sein scheint, also ein RW-Laufwerk mittendrin sagt an das keine DVD erkannt wird, kann aber auch sein das Laufwerk hat eine Macke. Ein einfaches ROM-LW am selben Kabel funktioniert.

    ----

    PC | AMD Ryzen 7 5700X | Radeon RX6600 | 32GB RAM | 1,5TB NVMe | Manjaro KDE Kernel 5.18 + Windows 11

    NB | AMD Ryzen 5 5300U | Radeon Vega 8 | 16GB RAM | 512GB NVMe | Debian 11 Kernel 5.18



  • Post by Reiner660 ().

    This post was deleted by harihegen: Kapern des Threads, von nicoletta angemahnt und daher gelöscht ().
  • Was macht man damit?

    DVD Datenträger auslesen, hintereinander weg, ohne immer eine nach der anderen zu wechseln.

    ----

    PC | AMD Ryzen 7 5700X | Radeon RX6600 | 32GB RAM | 1,5TB NVMe | Manjaro KDE Kernel 5.18 + Windows 11

    NB | AMD Ryzen 5 5300U | Radeon Vega 8 | 16GB RAM | 512GB NVMe | Debian 11 Kernel 5.18



  • es geht um folgendes: ich habe zwei Festplatten verbaut, auf der einen läuft das Betribssystem, auf der anderen sind meine Fotos. Nur die Fotos kann ich runterkopieren auf die andere Fesplatte aber ich kann darauf nicht speichern

    Das hört sich danach an als ob du keine Schreibrechte auf der Festplatte hast auf der du die Fotos speichern möchtest.
    Du kannst mit der Maus einen Rechtsklick auf das Laufwerk, also die Festplatte machen und dort "Eigenschaften" aufrufen. Dann kommt ein Fenster in dem die Berechtigungen dargestellt werden. Bei mir sieht das so aus:


    Mach das mal :) und mache dazu ein neues Thema hier im Forum auf.

    ----

    PC | AMD Ryzen 7 5700X | Radeon RX6600 | 32GB RAM | 1,5TB NVMe | Manjaro KDE Kernel 5.18 + Windows 11

    NB | AMD Ryzen 5 5300U | Radeon Vega 8 | 16GB RAM | 512GB NVMe | Debian 11 Kernel 5.18



Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!