Problem mit HiFi-Anlage

  • Hallo Leute,

    ich bin ganz frisch hier gelandet. Meine letzten Linux-Erfahrungen sind an die 15 Jahre her und waren... Nunja, schwierig. Aber inzwischen hat sich ja ne wirklich große Menge getan, so wollte ich es mal wieder probieren.

    Ich hab also den Feiertag damit verbracht, Fedora 40 mit KDE Plasma neben meinem Windows 11 zu installieren. Soweit funktioniert auch tatsächlich alles ootb sehr gut und ich bin recht angetan.

    Allerdings habe ich ein wirklich nerviges Problem, für das ich auch nach einigen Stunden Suchmaschinenbedienung noch keine funktionierende Lösung gefunden habe. Und zwar ist die Sache die: Ich hab meinen PC über Line Out an eine alte HiFi-Anlage angeschlossen. Das war auch tatsächlich noch nie ein Problem. Aber unter Linux scheint es so zu sein, dass PipeWire(?) die Soundkarte nach einigen Sekunden Leerlauf in einen Idle-Modus schaltet, der zu einem ohrenbetäubendem Brummen aus meinen Lautsprechern führt. Wenn Musik oder sonst was läuft, was den Soundchip beansprucht, ist alles gut, der Klang ist klar und deutlich und ohne Störgeräusche. Kaum drück ich aber auf Pause vergehen 3-5 Sekunden, und das Brummen ist zurück.

    Weiß da zufällig jemand, was man dagegen tun kann? Ich hab vieles gelesen, man müsste was in config-Dateien auskommentieren. Der Versuch hat dazu geführt, dass ich das System direkt noch einmal neuinstallieren musste, weil ich die zerschossene config nicht wiederherstellen konnte, obwohl ich extra eine Sicherungskopie angelegt hatte.

    Bin ein bisschen ratlos. Und wie gesagt, ganz neu in der Linux-Materie. Wäre toll, wenn jemand ne Lösung wüsste!

    Danke schonmal vorab!

  • Oh je, Pipewire ist ziemlich neu, da werden sich noch nicht so viele mit auskennen. Klingt nach Stromsparfunktion. Kenne mich leider mit Fedora nicht aus. Vielleicht könnte man Pipewire deinstallieren und nur Pulsaudio benutzen.

    Linux Mint Mate auf ASUS Zenbook Flip UX360U; Armbian auf Banana Pi

  • Ich hatte mit meinem Onboard-Soundchip immer ein nerviges Knistern, sobald ich keinen Sound aktiv hatte. Habe dann im Internet den Workaround gefunden, die Energiesparfunktion des Soundtreibers zu deaktivieren. Bei mir half das und das Knistern war weg. Seitdem führe ich diesen Befehl einfach provisorisch nach jeder Installation aus.

    Probiere es doch einfach mal:

    Code
    echo options snd-hda-intel power_save=0 power_save_controller=N | sudo tee /etc/modprobe.d/hda.conf

    Schau aber am besten vorher mit dem Befehl lspci -n -n -k | grep -A 2 -e Audio -e 3D, ob dein Soundtreiber auch snd_hda_intel ist, dann trotzdem als Befehl wie oben beschrieben snd-hda-intel eingeben.

    Code
    [denalb@PROMETHEUS-ArchLinux ~]$ lspci -n -n -k | grep -A 2 -e Audio -e 3D
    2f:00.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] Navi 31 HDMI/DP Audio [1002:ab30]
    	Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] Navi 31 HDMI/DP Audio [1002:ab30]
    	Kernel driver in use: snd_hda_intel
    	Kernel modules: snd_hda_intel
    --
    31:00.4 Audio device [0403]: Advanced Micro Devices, Inc. [AMD] Starship/Matisse HD Audio Controller [1022:1487]
    	Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:ec84]
    	Kernel driver in use: snd_hda_intel

    Arch Linux | Gnome 46.2 | Kernel 6.9.2-arch1-1

    MSI MAG X570 Tomahawk WIFI | AMD Ryzen 9 3900X | 2x 16 GB G.Skill RipJaws V DDR4-3200 | Sapphire NITRO+ AMD Radeon RX 7800 XT | Seasonic Prime PX-750 80+ Platinum

    Edited once, last by DenalB: Befehl korrigiert! (May 7, 2024 at 1:39 PM).

  • Vielen Dank euch zwei für eure Antworten!

    Oh je, Pipewire ist ziemlich neu, da werden sich noch nicht so viele mit auskennen. Klingt nach Stromsparfunktion. Kenne mich leider mit Fedora nicht aus. Vielleicht könnte man Pipewire deinstallieren und nur Pulsaudio benutzen.

    Ja, das hatte ich auch so verstanden. Vermutlich deswegen hab ich da auch noch keine Lösung für gefunden, für Pulseaudio hingegen etliche Einträge im Netz... Aber nachdem ich ja sogar auf dem recht exotischen Tablet relativ problemlos ein Linux zum laufen bekommen habe, musste es ja passieren, dass ich auf ein Problem treffe, das ich nicht selbständig lösen kann. ^^

    Ich hatte mit meinem Onboard-Soundchip immer ein nerviges Knistern, sobald ich keinen Sound aktiv hatte. Habe dann im Internet den Workaround gefunden, die Energiesparfunktion des Soundtreibers zu deaktivieren. Bei mir half das und das Knistern war weg. Seitdem führe ich diesen Befehl einfach provisorisch nach jeder Installation aus.

    Probiere es doch einfach mal:

    Danke für den Tipp! Den hab ich so noch nicht gefunden!

    Werde das kommende Woche ausprobieren. Übers Wochenende bin ich nicht zuhause. Ich werde dann berichten. :thumbup:

  • Evtl hilft dir auch dass hier weiter

    How do I disable audio sink suspend on idle using WirePlumber in Fedora 35 so that audio isn't delayed when starting playback?
    In Fedora 35, WirePlumber has replaced pipewire-media-session as the audio session manager. There is a highly annoying problem with audio on many built-in…
    unix.stackexchange.com

    Hier wird suspend nicht im Kernel Modul sondern in den configs von pipewire und alsa deaktiviert.

  • Hallo zusammen,

    ich probieren gerade rum.

    Evtl hilft dir auch dass hier weiter

    https://unix.stackexchange.com/questions/6768…fedora-35-so-th

    Hier wird suspend nicht im Kernel Modul sondern in den configs von pipewire und alsa deaktiviert.

    Das scheint nicht zu funktionieren, weil es anscheinend diesen Pfad hier, in dem die configs liegen sollen, nicht gibt:

    /usr/share/wireplumber/main.lua.d/50-alsa-config.lua

    Jedenfalls finde ich ihn nicht. Ich komme nur bis /usr/share/wireplumber/

    Mag natürlich sein, dass ich da was grundlegendes falsch mache, aber dann hab ich leider keine Idee, was es sein könnte.

    Probiere es doch einfach mal:

    Code
    echo options snd_hda_intel power_save=0 power_save_controller=N | sudo tee /etc/modprobe.d/hda.conf

    Der Treiber scheint der richtige zu sein, er sagt, der Treiber sei snd_hda_intel.

    Der Befehl wird quittiert mit der Ausgabe:

    options snd_hda_intel power_save=0 power_save_controller=N

    Aber leider hat sich am Verhalten nichts geändert, nach wenigen Sekunden Inaktivität auf dem Soundchip geht das Brummen weiter.

  • Du wirst vermutlich dass Vereichniss und die Datei erst stellen müssen.

    um 2ten Punkt.

    Du wirst dass Kernel Modul erst neu laden müssen damit die Änderung wirksam wird. Dazu gibt es ebenfalls wieder mehr Wege. Entweder du fragst eine Suchmaschine oder du startest einfach neu.

    Vorher würde ich aber mit

    Code
    cat /etc/modprobe.d/hda.conf

    nachschauen ob wirklich dass richtige in der hda.conf steht.

  • Aber leider hat sich am Verhalten nichts geändert

    Neustart des Rechners hattest du danach durchgeführt?

    Arch Linux | Gnome 46.2 | Kernel 6.9.2-arch1-1

    MSI MAG X570 Tomahawk WIFI | AMD Ryzen 9 3900X | 2x 16 GB G.Skill RipJaws V DDR4-3200 | Sapphire NITRO+ AMD Radeon RX 7800 XT | Seasonic Prime PX-750 80+ Platinum

  • Quote

    Du wirst vermutlich dass Vereichniss und die Datei erst stellen müssen.

    Das Problem scheint mir zu sein, dass ich eine Datei, die bereits in diesem Verzeichnis liegen soll, ändern muss. Aber wenn es das Verzeichnis nicht gibt, ist das wohl schlecht möglich, oder?

    um 2ten Punkt.

    Du wirst dass Kernel Modul erst neu laden müssen damit die Änderung wirksam wird. Dazu gibt es ebenfalls wieder mehr Wege. Entweder du fragst eine Suchmaschine oder du startest einfach neu.

    Vorher würde ich aber mit

    Code
    cat /etc/modprobe.d/hda.conf

    nachschauen ob wirklich dass richtige in der hda.conf steht.

    Neustart hatte ich natürlich gemacht.

    Konsole gibt aus

    options snd_hda_intel power_save=0 power_save_controller=N

    Neustart des Rechners hattest du danach durchgeführt?

    Ja, natürlich, inzwischen sogar mehrfach.

    Der Vollständigkeit halber hier auch nocheinmal die Ausgabe von lspci -n -n -k | grep -A 2 -e Audio -e 3D. Vielleicht hab ich ja da was übersehen und vorschnell gehandelt.

  • Versuche mal den Befehl so zu schreiben:
    echo options snd-hda-intel power_save=0 power_save_controller=N | sudo tee /etc/modprobe.d/hda.conf

    So war das bei mir in der Dokumentation vermerkt. Dachte, ich hätte mich verschrieben ...

    Die Datei /etc/modprobe.d/hda.conf müsste es nach Eingabe des Befehls auf jeden Fall geben.

    Arch Linux | Gnome 46.2 | Kernel 6.9.2-arch1-1

    MSI MAG X570 Tomahawk WIFI | AMD Ryzen 9 3900X | 2x 16 GB G.Skill RipJaws V DDR4-3200 | Sapphire NITRO+ AMD Radeon RX 7800 XT | Seasonic Prime PX-750 80+ Platinum

  • Versuche mal den Befehl so zu schreiben:
    echo options snd-hda-intel power_save=0 power_save_controller=N | sudo tee /etc/modprobe.d/hda.conf

    So war das bei mir in der Dokumentation vermerkt. Dachte, ich hätte mich verschrieben ...

    Die Datei /etc/modprobe.d/hda.conf müsste es nach Eingabe des Befehls auf jeden Fall geben.

    Das scheint geklappt zu haben! Es herrscht nun jedenfalls Stille im Lautsprecher!

    Vielen Dank! :)

  • Da es jetzt funktioniert ist ja alles gut, aber noch kurz m Abschluss.

    Das Problem scheint mir zu sein, dass ich eine Datei, die bereits in diesem Verzeichnis liegen soll, ändern muss. Aber wenn es das Verzeichnis nicht gibt, ist das wohl schlecht möglich, oder?

    Wenn eine Config Datei leer ist wir sie bei der Installation meist nicht mit erzeugt, ebenso wie Verzeichnisse. Es ist auch der Name meist egal da dass Programm in dem Verzeichniss nach allen Config Dateien sucht und diese abarbeitet.

  • Das scheint geklappt zu haben! Es herrscht nun jedenfalls Stille im Lautsprecher!

    Super! Dann ändere ich den Befehl in meinem ursprünglichen Beitrag mal entsprechend ab. ;)

    Arch Linux | Gnome 46.2 | Kernel 6.9.2-arch1-1

    MSI MAG X570 Tomahawk WIFI | AMD Ryzen 9 3900X | 2x 16 GB G.Skill RipJaws V DDR4-3200 | Sapphire NITRO+ AMD Radeon RX 7800 XT | Seasonic Prime PX-750 80+ Platinum

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!